TSDuck v3.46-4930
MPEG Transport Stream Toolkit
Loading...
Searching...
No Matches
ts::mcast Namespace Reference

Classes

class  BaseMulticastTransportSession
class  FDTInstanceHeader
class  FECPayloadId
class  FECTransmissionInformation
class  FluteAnalyzer
class  FluteAnalyzerArgs
class  FluteDemux
class  FluteDemuxArgs
class  FluteFDT
class  FluteFile
class  FluteHandlerInterface
class  FlutePlugin
class  FluteSessionId
class  ForwardErrorCorrectionParameters
class  GatewayConfiguration
class  GatewayConfigurationTransportSession
class  LCTHeader
class  MulticastSession
class  NetworkInformationFile
class  NIPActualCarrierInformation
class  NIPAnalyzer
class  NIPAnalyzerArgs
class  NIPDemux
class  NIPExtractPlugin
class  NIPHandlerInterface
class  NIPPlugin
class  NIPService
class  NIPStreamId
class  ReportingLocator
class  ServiceInformationFile
class  ServiceList
class  ServiceListEntryPoints
class  TransportProtocol

Enumerations

enum  : uint8_t {
  HET_MIN_VAR_SIZE = 0 ,
  HET_NOP = 0 ,
  HET_AUTH = 1 ,
  HET_TIME = 2 ,
  HET_FTI = 64 ,
  HET_TOL48 = 67 ,
  HET_NACI = 68 ,
  HET_MAX_VAR_SIZE = 127 ,
  HET_MIN_FIXED_SIZE = 128 ,
  HET_FDT = 192 ,
  HET_CENC = 193 ,
  HET_TOL24 = 194 ,
  HET_MAX_FIXED_SIZE = 255
}
enum  : uint8_t {
  CENC_NULL = 0 ,
  CENC_ZLIB = 1 ,
  CENC_DEFLATE = 2 ,
  CENC_GZIP = 3
}
enum  : uint8_t {
  FEI_COMPACT_NOCODE = 0 ,
  FEI_RAPTORQ = 6 ,
  FEI_EXPANDABLE = 128 ,
  FEI_SMALL_BLOCK = 129 ,
  FEI_COMPACT = 130
}
enum  : uint8_t {
  ROUTE_CP_NONE = 0 ,
  ROUTE_CP_NRT_FILE = 1 ,
  ROUTE_CP_NRT_ENTITY = 2 ,
  ROUTE_CP_NRT_UNSIGNED = 3 ,
  ROUTE_CP_NRT_SIGNED = 4 ,
  ROUTE_CP_NEW_IS_CHANGED = 5 ,
  ROUTE_CP_NEW_IS_CONTINUE = 6 ,
  ROUTE_CP_REDUNDANT_IS = 7 ,
  ROUTE_CP_MEDIA_FILE = 8 ,
  ROUTE_CP_MEDIA_ENTITY = 9 ,
  ROUTE_CP_MEDIA_RAC = 10
}
enum  FileTransport {
  FT_UNKNOWN ,
  FT_FLUTE ,
  FT_ROUTE
}

Functions

const IPSocketAddress & NIPSignallingAddress4 ()
const IPSocketAddress & NIPSignallingAddress6 ()

Variables

constexpr uint64_t FLUTE_FDT_TOI = 0
constexpr uint64_t INVALID_TSI = std::numeric_limits<uint64_t>::max()
constexpr uint16_t NIP_SIGNALLING_PORT = 3937
constexpr uint64_t NIP_SIGNALLING_TSI = 0

Detailed Description

Namespace for advanced forms of television over multicast.

Enumeration Type Documentation

◆ anonymous enum

anonymous enum : uint8_t

FEC Encoding ID values for FLUTE and LCT.

See also
IETF RFC 3926, section 5.1.4
Enumerator
FEI_COMPACT_NOCODE 

Compact No-Code FEC (Fully-Specified).

FEI_RAPTORQ 

RaptorQ FEC Scheme (RFC 6330).

FEI_EXPANDABLE 

Small Block, Large Block and Expandable FEC (Under-Specified).

FEI_SMALL_BLOCK 

Small Block Systematic FEC (Under-Specified).

FEI_COMPACT 

Compact FEC (Under-Secified).

◆ anonymous enum

anonymous enum : uint8_t

Header Extension Types (HET) for Layered Coding Transport (LCT).

Enumerator
HET_MIN_VAR_SIZE 

Min type value for variable-size header extensions.

HET_NOP 

No-Operation extension.

HET_AUTH 

Packet authentication extension.

HET_TIME 

Time extension.

HET_FTI 

FEC Object Transmission Information extension (ALC, RFC 5775).

HET_TOL48 

ATSC Transport Object Length, 48-bit version (ATSC A/331, section A.3.8.1).

HET_NACI 

NIP Actual Carrier Information (DVB-NIP, ETSI TS 103 876).

HET_MAX_VAR_SIZE 

Max type value for variable-size header extensions.

HET_MIN_FIXED_SIZE 

Min type value for fixed-size header extensions (24-bit payload).

HET_FDT 

FDT Instance Header (FLUTE, RFC 3926).

HET_CENC 

FDT Instance Content Encoding extension (FLUTE, RFC 3926).

HET_TOL24 

ATSC Transport Object Length, 24-bit version (ATSC A/331, section A.3.8.1).

HET_MAX_FIXED_SIZE 

Max type value for fixed-size header extensions (24-bit payload).

◆ anonymous enum

anonymous enum : uint8_t

Content encoding values in HET_CENC header of Layered Coding Transport (LCT).

Enumerator
CENC_NULL 

No encoding, raw data.

CENC_ZLIB 

ZLib encoding [RFC1950].

CENC_DEFLATE 

Deflate encoding [RFC1951].

CENC_GZIP 

GZip encoding [RFC1952].

◆ anonymous enum

anonymous enum : uint8_t

Codepoint values in LCT headers with ROUTE protocol. "IS" stands for Initialization Segment of the media content such as the DASH Initialization Segment.

See also
RFC 9223, section 2.1
Enumerator
ROUTE_CP_NONE 

Reserved (not used).

ROUTE_CP_NRT_FILE 

Non Real Time (NRT) - File Mode.

ROUTE_CP_NRT_ENTITY 

NRT - Entity Mode.

ROUTE_CP_NRT_UNSIGNED 

NRT - Unsigned Package Mode.

ROUTE_CP_NRT_SIGNED 

NRT - Signed Package Mode.

ROUTE_CP_NEW_IS_CHANGED 

New IS, timeline changed.

ROUTE_CP_NEW_IS_CONTINUE 

New IS, timeline continued.

ROUTE_CP_REDUNDANT_IS 

Redundant IS.

ROUTE_CP_MEDIA_FILE 

Media Segment, File Mode.

ROUTE_CP_MEDIA_ENTITY 

Media Segment, Entity Mode.

ROUTE_CP_MEDIA_RAC 

Media Segment, File Mode with CMAF Random Access Chunk.

◆ FileTransport

Logical definition of a unicast file transport protocol.

Enumerator
FT_UNKNOWN 

Unrecognized protocol.

FT_FLUTE 

File Delivery over Unidirectional Transport, RFC 3926 (v1), RFC 6726 (v2).

FT_ROUTE 

Real-Time Transport Object Delivery over Unidirectional Transport, RFC 9223.

Function Documentation

◆ NIPSignallingAddress4()

const IPSocketAddress & ts::mcast::NIPSignallingAddress4 ( )

Get the DVB-NIP signalling IPv4 address and port (224.0.23.14, UDP port 3937).

Returns
A constant reference to the DVB-NIP signalling IPv4address.
See also
ETSI TS 103 876, section 8.2.2

◆ NIPSignallingAddress6()

const IPSocketAddress & ts::mcast::NIPSignallingAddress6 ( )

Get the DVB-NIP signalling IPv6 address and port (FF0X:0:0:0:0:0:0:12D, UDP port 3937).

Returns
A constant reference to the DVB-NIP signalling IPv6 address (with scope bits set to zero).
See also
ETSI TS 103 876, section 8.2.2

Variable Documentation

◆ FLUTE_FDT_TOI

uint64_t ts::mcast::FLUTE_FDT_TOI = 0
constexpr

LCT Transport Object Identifier for FLUTE File Delivery Table (FDT).

See also
IETF RFC 3926, section 3.3

◆ INVALID_TSI

uint64_t ts::mcast::INVALID_TSI = std::numeric_limits<uint64_t>::max()
constexpr

Invalid Transport Session Identifier (TSI) value, to be used as placeholder.

◆ NIP_SIGNALLING_TSI

uint64_t ts::mcast::NIP_SIGNALLING_TSI = 0
constexpr

DVB-NIP signalling TSI Transport Session Identifier (LCT) value.

See also
ETSI TS 103 876, section 8.2.2

◆ NIP_SIGNALLING_PORT

uint16_t ts::mcast::NIP_SIGNALLING_PORT = 3937
constexpr

DVB-NIP signalling UDP port.

See also
ETSI TS 103 876, section 8.2.2